Tuesday, December 30, 2008

Unable to process the objects in Analysis Services but deploy

This ate few minutes from my allocated time :). I was able to successfully deploy the Analysis Services 2008 project to another server that has only SSAS 2008 installed but had no way of processing. I was able to connect to the SSAS via MS too and see the deployed items but it did not allow me to process too. This was the error; OLE DB error: OLE DB or ODBC error: Login timeout expired; HYT00; A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.; 08001; Named Pipes Provider: Could not open a connection to SQL Server [2]. ; 08001. I was bit confused but finally figured out the problem. The issue was with the data source. Though the connection string that was used with data source in the project can be used for connecting to the data source, once deployed, SSAS cannot connect to the data source via same credential. I changed the credential of project's the data source that allows to connect to the data source from both machine. Finally I was able to deploy and process the objects :). You may face for same, hence shared it.

4 comments:

Sugeesh said...

Thanks Dinesh. Your post saved me a time in fixing the same problem I had.

Artemisx said...

Helped me as well, thanks Dinesh!

shiwa said...

Coming to SSAS , I am defining a datasource. It asked for windows
impersonation information. What do I need to select? I have 4 options




1. Use a specific windows username and password

2. use service account

3. use credentials of the current user

4. inherit



what do i need to select



1. If i select 1 option, whats my username and password.


my system name is shiva-PC

administrator user : is shiva

password : shiva



Is that what i need to enter.

or anything else.???



Please explain me clearly as i am not technically sound


I am using windows authentication for connecting to SQL mgmt studio.



Please respond.!!

ravi said...

Thank you Dinesh.. It really helped me a lot and saved a lot of time.